Help Center

Premiere composer requires Adobe Premiere Pro version 13.0.0 or later